System Maintenance
Resolved
Jul 12, 2026 at 11:00am UTC
Maintenance ended
Affected services
Updated
Jul 12, 2026 at 10:54am UTC
We are now finishing up.
Affected services
Updated
Jul 12, 2026 at 9:54am UTC
We have hit some delays. Maintenance has been changed from ending at 10 PM to ending at 11 PM
Affected services
Created
Jul 12, 2026 at 9:00am UTC
On July 12, we will be performing system maintenance to update server software and services. We will also be conducting load testing during this window. Users should expect extended load times, timeouts, and brief service interruptions.
All websites should be fully operational after the maintenance window has closed. If anything goes wrong, the window may be extended, and updates will be provided.
Affected services